Supernova Auto Installer

Introduction

The Supernova Automatic Installer seeks to automate user installation.  It uses the Ashita windowing program as its default, so any users wishing to use Windower4 will need to follow the manual installation instructions.

Microsoft .NET Framework 3.5 is required to install FFXI and this installer will check if you have it installed or not and will not continue if you do not have it installed. (people should technically have this already unless it’s a new install of windows)
Download the .NET Framework 3.5 here

The Automatic Installer can be downloaded here or can be located on the right side of the page.

Installation Notes

  • Some scripts in the installer may trigger anti-virus systems or firewalls to block it. If this happens either whitelist the program in the firewall and temp disable any antivirus software.
  • Occasionally but not too often the patch will run into a snag, to prevent the system from locking I made it so it will bypass and continue on if that’s the case. If FFXI is not in the file check list in PlayOnline, then close the installer entirely and run it again. It Will repair what it missed and the game should be in the file check list now.
  • Ashita’s installer will automatically replace the Supernova Private Server Entry with Dark Legion’s (this was by design of the Ashita developers). To remedy this I had to do some things to bypass that annoying part without damaging files. When Ashita launches to update files, Supernova’s entry will be there but the program will give a bug error for some unknown reason. Close Ashita and launch it again and it will work perfectly fine.

Forward all issues or general inquiries with the installer to Supernova Discord channel #ffxisupport and directed to @Duriel.

Advertisements